Back to overview
Downtime
Downloader and Randomizer are down
Mar 23, 2022 at 10:13pm UTC
Resolved
Mar 23, 2022 at 10:56pm UTC
Working correctly for now
Affected services
Created
Mar 23, 2022 at 10:13pm UTC
We are investigating the cause of the issue
Affected services