Back to overview
Downtime

Some services are down

Oct 15 at 09:11pm CEST
Affected services
Website
Show Canvas
Get random Canvas

Resolved
Oct 17 at 03:21pm CEST

The services are working again for now!
I can't confirm that it'll last very long though.

Created
Oct 15 at 09:11pm CEST

Showing Canvas and Getting a random Canvas are unavailable for an indeterminate period.
This is due to Spotify making changes in their systems.
Sorry for the inconvenience, please try looking for Canvas by searching for the artist name instead.
Thank you for using Canvas Downloader!